vue cli3兼容IE11心酸过程

bug描述

近期做了一个项目,经过测试发现在IE浏览器上面打不开,结果IE浏览器报错如下,然后开始各种找错误,看到打包后的文件报错,有点懵,在项目中debug了一圈没发现错误,偶尔在网上搜到,可能因为swiper的版本导致的,然后就开始尝试

cli1
cli2

兼容性代码

1.现在本地安装一个babel-polyfill

//main.js 
import 'babel-polyfill'    //需要先 npm i babel-polyfill -D

2.把本地的swiper 5.x版本降到"swiper": "^3.4.2",然后重启项目,再去IE上测试发现可以展示了

共有 0 条评论

Top